4/11/2014

Notice regarding Heartbleed bug

News reports have surfaced about a software security vulnerability, referred to as “Heartbleed” or “Open SSL Technology” affecting some internet sites. BankFIRST is happy to report that we do not run the impacted version of this software and none of our Online Banking Services has been affected.
 
Protecting the safety and security of your personal and financial information is a top priority at BankFIRST!